관리 메뉴

솜씨좋은장씨

[Ubuntu] UserWarning: Could not import the lzma module. Your installed Python is incomplete. Attempting to use lzma compression will result in a RuntimeError. 해결방법 본문

유용한 정보/Ubuntu

[Ubuntu] UserWarning: Could not import the lzma module. Your installed Python is incomplete. Attempting to use lzma compression will result in a RuntimeError. 해결방법

사용자 솜씨좋은장씨 2021. 1. 13. 20:04

UserWarning: Could not import the lzma module. 
Your installed Python is incomplete. 
Attempting to use lzma compression will result in a RuntimeError. 

gunicorn을 사용하던 중 위와 같은 오류가 발생하게 되었습니다.

 

 

이를 해결 하는 방법은 다음과 같습니다.

$ sudo apt-get install liblzma-dev

apt-get install 명령어를 통하여 liblzma-dev를 설치해주면 됩니다.

 

그 다음 python을 한번 다시 컴파일 해주어야 합니다.

 

먼저 설치할 때 사용했던 파일들이 있는 디렉토리로 이동합니다.

 

만약 설치할 때 사용했던 파일들이 있는 디렉토리가 없다면 먼저 python 버전을 확인한 후에 

아래의 링크를 참고하여 python파일을 다운로드 받아 활용하기 바랍니다.

$ python3 -V
3.7.4
 

[Python]Ubuntu에 Python 3.7 설치하기!

1. Python 설치 전 라이브러리 설치하기 Ubuntu(또는 Putty)에서 터미널을 열어 아래의 코드를 입력합니다. 설치 중간 중간에 [ y | n ] 중에 고르라고 나오면 y를 타이핑하고 엔터를 해주시면 됩니다! $ s

somjang.tistory.com

 

설치할 때 사용했던 파일들이 있는 디렉토리로 이동하여 

$ cd Python-3.7.4 
$ ./configure 
$ make 
$ sudo make install

 

위의 명령어를 차례대로 실행한 뒤 python -V 명령어를 통하여 기존에 설치했던 버전과 동일한 버전인지 확인합니다.

$ python3 -V
3.7.4

동일하게 잘 나온다면 완료입니다.

 

읽어주셔서 감사합니다.

0 Comments
댓글쓰기 폼