관리 메뉴

솜씨좋은장씨

[React] error c8@7.7.3: The engine "node" is incompatible with this module. Expected version ">=10.12.0". Got "10.10.0" 해결방법 ( feat. nvm ) 본문

Programming/React

[React] error c8@7.7.3: The engine "node" is incompatible with this module. Expected version ">=10.12.0". Got "10.10.0" 해결방법 ( feat. nvm )

솜씨좋은장씨 2021. 7. 1. 22:44
728x90
반응형

 

macOS에 nvm설치하는 방법! ( feat. brew )

macOS에서는 brew라는 아주 편리한 친구가 있습니다. 먼저 아래의 링크를 참고하여 brew를 설치합니다. 1. brew 설치하기 [Mac OSX] Brew 설치하기 먼저 Brew 홈페이지로 이동합니다. https://brew.sh/index_ko H..

somjang.tistory.com

 

[React] yarn과 create-react-app 설치하고 리액트 앱 생성, 실행하는 방법

1. yarn 설치하기 $ npm install -g yarn 2. create-react-app을 활용하여 리액트 앱 생성하기 $ yarn create react-app react-study-first-time --scripts-version 2.1.7 3. 생성한 리액트 앱 실행하기 $ cd rea..

somjang.tistory.com

nvm을 활용해서 Node.js를 설치하고 create-react-app을 활용하여 리액트 앱을 생성한 뒤에

packge.json을 수정하고 yarn을 통해 라이브러리를 설치하려고 하였는데

[2/4] 🚚  Fetching packages...
error c8@7.7.3: The engine "node" is incompatible with this module. Expected version ">=10.12.0". Got "10.10.0"
error Found incompatible module.
info Visit https://yarnpkg.com/en/docs/cli/install for documentation about this command.

위와 같은 오류가 발생했습니다.

 

위의 오류는 Node.js의 버전이 달라서 나는 오류입니다.

 

저는 nvm을 설치했기때문에 nvm을 활용해서 Node.js의 버전을 바꿔보기로 했습니다.

먼저 위의 오류에서 10.12.0 이상 버전의 Node.js가 필요하다고 했으니 10.12.0 버전을 nvm을 활용하여 설치하였습니다.

$ nvm install 10.12.0

그 다음 10.12.0 버전을 사용하도록 아래의 명령어로 변경해주면 됩니다.

$ nvm use 10.12.0

그런 다음 다시 설치를 해보면!

[4/4] 🔨  Building fresh packages...
success Saved lockfile.
✨  Done in 68.38s.

제대로 잘 설치가 되는 것을 볼 수 있습니다.

 

읽어주셔서 감사합니다.

728x90
반응형
0 Comments
댓글쓰기 폼